• Problems in Perl tests on Rmfiles

    From Fabio Bizzi@2:335/364 to Michael Dukelsky on Monday, May 03, 2021 10:35:18
    Hello Michael!

    I'm trying to use the perl utilities from the GIT util repository and I'm following the build instructions.

    The building of Fidoconfig-Token runs without issue, I built and installed it flawless.

    Instead When I run the Build test on Husky-Rmfiles I get lot of errors.

    Please can I send to you the file with the output of Build test so you can take
    a look at it?

    Many Thanks.

    Ciao!
    Fabio
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ]\/[imac Rebirth (2:335/364)
  • From Michael Dukelsky@2:5020/1042 to Fabio Bizzi on Monday, May 03, 2021 11:51:48
    Hello Fabio,

    Monday May 03 2021, Fabio Bizzi wrote to Michael Dukelsky:

    I'm trying to use the perl utilities from the GIT util repository and
    I'm following the build instructions.

    The building of Fidoconfig-Token runs without issue, I built and
    installed it flawless.

    Instead When I run the Build test on Husky-Rmfiles I get lot of
    errors.

    Please can I send to you the file with the output of Build test so you
    can take a look at it?

    Yes, sure.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Michael Dukelsky@2:5020/1042 to Fabio Bizzi on Monday, May 03, 2021 14:08:04
    Hello Fabio,

    Monday May 03 2021, Fabio Bizzi wrote to Michael Dukelsky:

    Instead When I run the Build test on Husky-Rmfiles I get lot of
    errors.

    Fixed.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Fabio Bizzi@2:335/364 to Michael Dukelsky on Monday, May 03, 2021 14:52:04
    Hello Michael!

    03 May 21 14:08, you wrote to me:

    Instead When I run the Build test on Husky-Rmfiles I get lot of
    errors.

    Fixed.

    There is still a problem:

    8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--

    ftn@balabam:~/src/husky-git/master/util/Husky-Rmfiles$ ./Build test t/00_mkdir.t ...................... ok
    t/01_load.t ....................... ok
    t/02_OS.t ......................... ok
    t/03_init.t ....................... ok
    t/04_unsubscribe.t ................ ok
    t/05_rmFilesFromOutbound.t ........ ok
    t/06_rmFilesFromFilebox.t ......... ok
    t/07_rmOrphanFiles.t .............. ok
    t/08_rmOrphanFilesFromOutbound.t .. ok
    t/09_rmLinkDefinition.t ........... ok
    t/10_report.t ..................... 2/?
    # Failed test 'report to JAM echobase'
    # at t/10_report.t line 469.
    # got: '1'
    # expected: '0'
    # Looks like you failed 1 test of 2.
    t/10_report.t ..................... Dubious, test returned 1 (wstat 256, 0x100) Failed 1/2 subtests
    t/11_rmdir.t ...................... ok

    Test Summary Report
    -------------------
    t/10_report.t (Wstat: 256 Tests: 2 Failed: 1)
    Failed test: 2
    Non-zero exit status: 1
    Files=12, Tests=284, 16 wallclock secs ( 0.51 usr 0.09 sys + 12.44 cusr 2.08 csys = 15.12 CPU)
    Result: FAIL
    Failed 1/12 test programs. 1/284 subtests failed.

    8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--8<--

    Thank you. :)

    Ciao!
    Fabio
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ]\/[imac Rebirth (2:335/364)
  • From Michael Dukelsky@2:5020/1042 to Fabio Bizzi on Monday, May 03, 2021 16:09:48
    Hello Fabio,

    Monday May 03 2021, Fabio Bizzi wrote to Michael Dukelsky:

    There is still a problem:

    t/10_report.t ..................... 2/?
    # Failed test 'report to JAM echobase'
    # at t/10_report.t line 469.
    # got: '1'
    # expected: '0'
    # Looks like you failed 1 test of 2.
    t/10_report.t ..................... Dubious, test returned 1 (wstat
    256, 0x100) Failed 1/2 subtests

    Hm. It is strange. I cloned huskyproject/util from github from scratch, ran all
    the actions to install both packages and the tests were finished without an error.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Fabio Bizzi@2:335/364.1 to Michael Dukelsky on Wednesday, May 05, 2021 08:58:14
    Hello Michael!

    03 May 21 16:09, you wrote to me:

    [...]
    t/10_report.t ..................... Dubious, test returned 1
    (wstat 256, 0x100) Failed 1/2 subtests

    Hm. It is strange. I cloned huskyproject/util from github from
    scratch, ran all the actions to install both packages and the tests
    were finished without an error.

    May I help somehow? :)

    Ciao!
    Fabio

    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ]\/[imac Rebirth Boss Point (2:335/364.1)
  • From Michael Dukelsky@2:5020/1042 to Fabio Bizzi on Thursday, May 06, 2021 21:47:06
    Hello Fabio,

    Wednesday May 05 2021, Fabio Bizzi wrote to Michael Dukelsky:

    [...]
    t/10_report.t ..................... Dubious, test returned 1
    (wstat 256, 0x100) Failed 1/2 subtests

    Fixed.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Fabio Bizzi@2:335/364.1 to Michael Dukelsky on Friday, May 07, 2021 09:05:22
    Hello Michael!

    06 May 21 21:47, you wrote to me:

    [...]
    t/10_report.t ..................... Dubious, test returned 1
    (wstat 256, 0x100) Failed 1/2 subtests

    Fixed.

    Thank you Michael! :)

    Ciao!
    Fabio
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ]\/[imac Rebirth Boss Point (2:335/364.1)