• FIDOCONFIG environment

    From Alan Ianson@1:153/757 to All on Friday, March 12, 2021 00:46:30
    Hello All,

    I just built husky on my desktop fresh just for a look. I haven't set a FIDOCONFIG environment previously and hpt and htick could always find the config as I set it in huskymak.cfg but currently husky can't find it's config unless I set the FIDOCONFIG environment.

    No a problem really, I can set that environment but is it supposed to work that
    way?

    Ttyl :-),
    Al

    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757)
  • From Michael Dukelsky@2:5020/1042 to Alan Ianson on Friday, March 12, 2021 12:21:26
    Hello Alan,

    Friday March 12 2021, Alan Ianson wrote to All:

    I just built husky on my desktop fresh just for a look. I haven't set
    a FIDOCONFIG environment previously and hpt and htick could always
    find the config as I set it in huskymak.cfg but currently husky can't
    find it's config unless I set the FIDOCONFIG environment.

    Looks like you changed the way you built the program. How do you do it now and how did you do it previously?

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Alan Ianson@1:153/757 to Michael Dukelsky on Friday, March 12, 2021 03:37:34
    Hello Michael,

    Looks like you changed the way you built the program.

    I was wondering that or if I made a mistake in huskymak.cfg but I don't see it.

    How do you do it now and how did you do it previously?

    I first copy huskymak.cfg from huskybse to the root directory and change LIBDIR
    to lib64, and enable hptzip and perl.

    I also change CFGDIR to $(PREFIX)/etc normally.

    In my last build I set..

    CFGDIR=/usr/local/etc

    but that made no difference.

    Then I run make, then "sudo make install" in these directories, in this order. huskylib
    smapi
    fidoconfig
    hptzip
    areafix
    hpt
    htick
    sqpack
    nltools
    msged

    The build looks good and works if I set the FIDOCONFIG environment or use -c /usr/local/etc/config on the command line.

    I've been doing it like that for as long as I can remember.

    Ttyl :-),
    Al

    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757)
  • From Oli@2:280/464.47 to Alan Ianson on Friday, March 12, 2021 14:23:22
    Alan wrote (2021-03-12):

    Hello All,

    I just built husky on my desktop fresh just for a look. I haven't set a FIDOCONFIG environment previously and hpt and htick could always find the config as I set it in huskymak.cfg but currently husky can't find it's config unless I set the FIDOCONFIG environment.

    No a problem really, I can set that environment but is it supposed to
    work that way?

    Interesting, I have the same problem with a recent build.

    ---
    * Origin: . (2:280/464.47)
  • From Tommi Koivula@2:221/6 to Oli on Friday, March 12, 2021 16:10:20
    On 12.03.2021 14:23, Oli wrote:

    I just built husky on my desktop fresh just for a look. I haven't set a FIDOCONFIG environment previously and hpt and htick could always find
    the
    config as I set it in huskymak.cfg but currently husky can't find it's config unless I set the FIDOCONFIG environment.

    No a problem really, I can set that environment but is it supposed to work that way?

    Interesting, I have the same problem with a recent build.

    Third one here! I first thought it was my restored backup...

    Apparently not.

    'Tommi

    ---
    * Origin: nntp://news.fidonet.fi (2:221/6.0)
  • From Alan Ianson@1:153/757 to Oli on Friday, March 12, 2021 20:31:13
    Hello Oli,

    No a problem really, I can set that environment but is it
    supposed to work that way?

    Interesting, I have the same problem with a recent build.

    I think we were stumbling over CFGDIR but it seems to be working now.

    Ttyl :-),
    Al

    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757)
  • From andrew clarke@3:633/267 to Alan Ianson on Saturday, March 13, 2021 20:21:46
    On 2021-03-12 00:46:30, Alan Ianson (1:153/757) wrote to All:

    I just built husky on my desktop fresh just for a look. I haven't set a FIDOCONFIG environment previously and hpt and htick could always find
    the config as I set it in huskymak.cfg but currently husky can't find
    it's config unless I set the FIDOCONFIG environment.

    No a problem really, I can set that environment but is it supposed to
    work that way?

    In your huskymak.cfg it's possible the CFGDIR variable changed because you modified PREFIX.

    But it may be something else.

    In Linux you can unset FIDOCONFIG, install strace (Ubuntu: "apt install strace") then run:

    $ strace -o strace.out hpt toss

    $ grep open strace.out | tail
    ...

    openat(AT_FDCWD, "/etc/ftnconfig", O_RDONLY) = -1 ENOENT (No such file or directory)

    In my case it took me a while to find the source of "ftnconfig". I build HPT with CMake (which does not use huskymak.cfg), and it turns out this is set in fidoconf/CMakeLists.txt:

    set(CFGDIR "/etc/ftn" CACHE STRING "CFGDIR")

    But if you don't build with CMake, CFGDIR is found in huskymak.cfg.

    --- GoldED+/BSD 1.1.5-b20180707
    * Origin: Blizzard of Ozz, Melbourne, Victoria, Australia (3:633/267)
  • From Alan Ianson@1:153/757 to andrew clarke on Saturday, March 13, 2021 01:55:15
    Hello andrew,

    No a problem really, I can set that environment but is it
    supposed to work that way?

    In your huskymak.cfg it's possible the CFGDIR variable changed because
    you modified PREFIX.

    But it may be something else.

    I'm not sure what caused the issue but Michael has made changes and CFGDIR is working as expected now.

    But if you don't build with CMake, CFGDIR is found in huskymak.cfg.

    I just build with make, old fashioned maybe but it works. :)

    Ttyl :-),
    Al

    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757)
  • From Oli@2:280/464.47 to Alan Ianson on Sunday, March 14, 2021 10:19:00
    Alan wrote (2021-03-12):

    Hello Oli,

    No a problem really, I can set that environment but is it
    supposed to work that way?

    Interesting, I have the same problem with a recent build.

    I think we were stumbling over CFGDIR but it seems to be working now.

    Same here, the problem has been solved by a fidoconf update :).

    ---
    * Origin: . (2:280/464.47)