• OS/2

    From Rick Smith@1:105/10.1 to All on Friday, January 22, 2021 21:11:20
    Greetings All!

    Looking to build and install husky on os/2 cant seem to accomplish it, any tips?

    fatal error: cannot execute 'emxomfld.exe'



    ----
    Regards,


    Rick Smith (Nitro)

    ... SURGEON GENERAL'S WARNING - BBSing may cause blindness.
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ----> Abacus Sysop Point --->>>>bbs.abon.us:2323 (1:105/10.1)
  • From Alan Ianson@1:153/757.2 to Rick Smith on Saturday, January 23, 2021 00:03:53
    Re: OS/2
    By: Rick Smith to All on Fri Jan 22 2021 09:11 pm

    Looking to build and install husky on os/2 cant seem to accomplish it, any tips?

    fatal error: cannot execute 'emxomfld.exe'

    I'm not sure what is needed to compile on OS/2.

    You can grab pre built binaries for all supported platforms and docs & source from..

    http://download.huskyproject.org

    Ttyl :-),
    Al

    ... I'm working on my 2nd $million... Gave up on the 1st.
    --- SBBSecho 3.12-Linux
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757.2)
  • From Stas Mishchenkov@2:460/5858 to Rick Smith on Saturday, January 23, 2021 11:45:58
    Hi Rick!

    Friday January 22 2021 21:11, you wrote to All:

    Looking to build and install husky on os/2 cant seem to accomplish it,
    any tips?

    fatal error: cannot execute 'emxomfld.exe'

    Why not use a pre-built package? http://download.huskyproject.org/os2/

    Have a nice night.
    Stas Mishchenkov.

    --- Have You daily sexual life? Hide it proper from Your wife! ;)
    * Origin: Lame Users Breeding. Simferopol, Crimea. (2:460/5858)
  • From Rick Smith@1:105/10.1 to Alan Ianson on Saturday, January 23, 2021 08:55:00
    Greetings Alan!

    Saturday January 23 2021 00:03, you wrote to me about an urgent matter!:

    * Forwarded from area 'fidosoft.husky'
    Re: OS/2
    By: Rick Smith to All on Fri Jan 22 2021 09:11 pm

    I'm not sure what is needed to compile on OS/2.

    You can grab pre built binaries for all supported platforms and docs & source from..

    http://download.huskyproject.org

    Thanks Al, yeah I think I am going to have to do that... Its funny you just get
    so used to building stuff, hardly think about just downloading it ready to go...

    ----
    Regards,


    Rick Smith (Nitro)

    ... I don't do drugs...BBSing is my escape from reality
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ----> Abacus Sysop Point --->>>>bbs.abon.us:2323 (1:105/10.1)
  • From Tommi Koivula@2:221/1.1 to Rick Smith on Saturday, January 23, 2021 20:21:26
    Hi Rick.

    22 Jan 21 21:11:20, you wrote to All:

    Looking to build and install husky on os/2 cant seem to accomplish it, any
    tips?

    fatal error: cannot execute 'emxomfld.exe'

    You need a working gcc compiler. :) Then just follow the instructions how to compile.

    I'm still using the good old GCC 3.3.5.

    === Cut ===
    cd huskylib\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd smapi\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd fidoconf\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd areafix\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd hpt\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd hptkill\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd hptutil\make
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -

    cd htick\os2
    make -f makefile.emx clean
    make -f makefile.emx all
    copy *.exe \husky\_src\build\
    cd -
    === Cut ===

    'Tommi

    ---
    * Origin: Point One (2:221/1.1)
  • From Alan Ianson@1:153/757.2 to Rick Smith on Saturday, January 23, 2021 15:28:54
    Re: OS/2
    By: Rick Smith to Alan Ianson on Sat Jan 23 2021 08:55 am

    http://download.huskyproject.org

    Thanks Al, yeah I think I am going to have to do that... Its funny you just get so used to building stuff, hardly think about just downloading it ready to go...

    It is possible I am sure but I am not sure of the tool chain needed. Tommi could get you moving in the right direction.

    There are gcc files released periodically in the GFD file areas (all sorts of OS/2 files) that might come in handy but I don't know how to build anything on OS/2. If you are not already connected to that FDN we could find a way to solve
    that.. :)

    Ttyl :-),
    Al

    ... Backup? I've never had troub**&{[} 3$$ERROR
    --- SBBSecho 3.12-Linux
    * Origin: The Rusty MailBox - Penticton, BC Canada (1:153/757.2)
  • From Michael Pierce@1:105/81 to Stas Mishchenkov on Thursday, January 28, 2021 14:47:34

    Hello Stas!

    23 Jan 21 11:45, you wrote to Rick Smith:

    Looking to build and install husky on os/2 cant seem to
    accomplish it, any tips?

    fatal error: cannot execute 'emxomfld.exe'

    Why not use a pre-built package? http://download.huskyproject.org/os2/

    Have a nice night.
    Stas Mishchenkov.

    I tried those binaries, and when I run hpt pack, I get killed by SIGSEGV error message

    this is on hpt/os-emx 1.9.0-cur 2020-11-09

    any ideas?

    Thanks
    Michael


    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Our Awesome Net - Portland, OR - awesome.abon.us (1:105/81)
  • From Stas Mishchenkov@2:460/5858 to Michael Pierce on Friday, January 29, 2021 07:10:58
    Hi Michael!

    Thursday January 28 2021 14:47, you wrote to me:

    Why not use a pre-built package?
    http://download.huskyproject.org/os2/


    I tried those binaries, and when I run hpt pack, I get killed by
    SIGSEGV error message

    this is on hpt/os-emx 1.9.0-cur 2020-11-09

    Do you mean http://download.huskyproject.org/os2/husky-all-1.9-os2-libc066-20201211.zip

    Husky 1.9-current OS/2-libc066 binaries only
    GIT snapshot date 11 Dec 2020
    Compiled with PERL=0, USE_HPTZIP=0

    Required libraries:
    LIBC v0.6.6
    ftp://ftp.netlabs.org/pub/gcc/libc-0.6.6-csd6.zip

    any ideas?

    It can be anything. For example, a non-existing path is specified in the config.


    Have a nice night.
    Stas Mishchenkov.

    --- Have You daily sexual life? Hide it proper from Your wife! ;)
    * Origin: Lame Users Breeding. Simferopol, Crimea. (2:460/5858)
  • From Kai Richter@2:240/77 to Michael Pierce on Friday, January 29, 2021 07:43:00
    Hello Michael!

    28 Jan 21, Michael Pierce wrote to Stas Mishchenkov:

    fatal error: cannot execute 'emxomfld.exe'

    any ideas?

    Do you have that exe on your system?

    As far as i remember there was some kind of path and compilier specific definitions in the huskymak.cfg. I would grep the sources for emxomfld.

    How did you start with the husky compilation? Where is your first entry point? And i don't know if there are differences between the OS/2 versions (Warp, ECS 1+2, etc.).

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)
  • From Michael Pierce@1:105/81 to Kai Richter on Saturday, January 30, 2021 17:02:50

    Hello Kai!

    29 Jan 21 07:43, you wrote to me:

    fatal error: cannot execute 'emxomfld.exe'

    any ideas?

    Do you have that exe on your system?
    no, I do not have that file on my system

    As far as i remember there was some kind of path and compilier
    specific definitions in the huskymak.cfg. I would grep the sources for emxomfld.

    I did not build, I downloaded the posted zip file with all the binaries

    How did you start with the husky compilation? Where is your first
    entry point? And i don't know if there are differences between the
    OS/2 versions (Warp, ECS 1+2, etc.).
    tried using the libs, which gave me klibc errors, cant seem to fix..everything seems to run fine unless I invoke the pack option

    have since decided to switch over to dbridge.

    Thank you for your time


    Michael


    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Our Awesome Net - Portland, OR - awesome.abon.us (1:105/81)
  • From Rick Smith@1:105/10.1 to Stas Mishchenkov on Sunday, January 31, 2021 11:38:26
    Greetings Stas!

    Sunday January 31 2021 10:42, you wrote to Michael Pierce about an urgent matter!:

    Hi Michael!

    Saturday January 30 2021 17:02, you wrote to Kai Richter:

    have since decided to switch over to dbridge.

    Try Regina-Tosser/2 http://dr-shost.com/files/rg05b104.rar

    Do you use this?



    ----
    Regards,


    Rick Smith (Nitro)

    ... BBSing is like sex, except you don't want to come off
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ----> Abacus Sysop Point --->>>>bbs.abon.us:2323 (1:105/10.1)
  • From Stas Mishchenkov@2:460/5858 to Rick Smith on Monday, February 01, 2021 07:54:52
    Hi Rick!

    Sunday January 31 2021 11:38, you wrote to me:

    have since decided to switch over to dbridge.

    Try Regina-Tosser/2 http://dr-shost.com/files/rg05b104.rar

    Do you use this?

    Yes. When I had OS/2, I used this tosser and was very pleased. It was written specifically for OS/2 and uses its features. Very fast.

    Have a nice night.
    Stas Mishchenkov.

    --- Have You daily sexual life? Hide it proper from Your wife! ;)
    * Origin: Lame Users Breeding. Simferopol, Crimea. (2:460/5858)
  • From Rick Smith@1:105/10.1 to Stas Mishchenkov on Sunday, January 31, 2021 22:15:20
    Greetings Stas!

    Monday February 01 2021 07:54, you wrote to me about an urgent matter!:

    * Forwarded from area 'fidosoft.husky'
    Hi Rick!

    Sunday January 31 2021 11:38, you wrote to me:

    have since decided to switch over to dbridge.

    Try Regina-Tosser/2 http://dr-shost.com/files/rg05b104.rar

    Do you use this?

    Yes. When I had OS/2, I used this tosser and was very pleased. It was written specifically for OS/2 and uses its features. Very fast.

    Any chance you know where I can get it in english? I cant setup because the docs are all in a language I cannot read.. Thank you.



    ----
    Regards,


    Rick Smith (Nitro)

    ... BBSing: Files, folks and fun.
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: ----> Abacus Sysop Point --->>>>bbs.abon.us:2323 (1:105/10.1)
  • From Michael Pierce@1:105/105 to Stas Mishchenkov on Monday, February 01, 2021 22:19:51
    Hi Michael!

    Saturday January 30 2021 17:02, you wrote to Kai Richter:

    have since decided to switch over to dbridge.

    Try Regina-Tosser/2 http://dr-shost.com/files/rg05b104.rar

    Is regina hardcoded to look in a certain place for its config files?
    it saved the config in the current folder, but when I run regina again, the configuration does not get loaded


    --- Have You daily sexual life? Hide it proper from Your wife! ;)
    lol

    --- D'Bridge 4
    * Origin: Mike's Playpen (1:105/105)
  • From Kai Richter@2:240/77 to Michael Pierce on Monday, February 01, 2021 11:29:26
    Hello Michael!

    30 Jan 21, Michael Pierce wrote to Kai Richter:

    fatal error: cannot execute 'emxomfld.exe'

    Do you have that exe on your system?
    no, I do not have that file on my system

    Oh sorry, my mistake. I didn't noticed the change of the topic.
    My question was intended for Rick. It does not match to your problem.

    tried using the libs, which gave me klibc errors, cant seem to fix..everything seems to run fine unless I invoke the pack option

    I'm afraid that we don't have many OS/2 users here. Did you try an OS2 echoarea
    to adress the OS2 community directly?

    have since decided to switch over to dbridge.

    Ouch. For OS/2 the hpt downgrade step should be squish/2. I did a migration from squish to hpt and it was easy from my point of view.

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)
  • From Kai Richter@2:240/77 to Rick Smith on Monday, February 01, 2021 11:51:30
    Hello Rick!

    22 Jan 21, Rick Smith wrote to All:

    Looking to build and install husky on os/2 cant seem to accomplish it,
    any tips?

    fatal error: cannot execute 'emxomfld.exe'

    Do you have that exe on your system?

    As far as i remember there was some kind of path and compilier specific definitions in the huskymak.cfg. I would grep the sources for emxomfld.

    How did you start with the husky compilation? Where is your first entry point? And i don't know if there are differences between the OS/2 versions (Warp, ECS 1+2, etc.).

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)
  • From Kai Richter@2:240/77 to Stas Mishchenkov on Monday, February 01, 2021 11:53:28
    Hello Stas!

    23 Jan 21, Stas Mishchenkov wrote to Rick Smith:

    Why not use a pre-built package?

    As far as i remember the control of dynamic vs static linking and included or excluded perl support.

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)