• tparser with sample config

    From Kai Richter@2:240/77 to Alle on Tuesday, April 19, 2022 12:43:40
    Hello!

    Fresh FreeBSD system, husky compiled with minimal conditions, sample configs with "gmake en". hpt without parameters start with: "hpt/fbsd 1.9 2022-02-08". Config path set, compiled and confirmed found by tparser.

    tparser/fbsd 1.9 2022-02-08
    Test /home/test/husky/config for all modules
    B 10:34:00 Enviroment variable [version] (used in config file /home/test/husky/config) is not defined and is replaced with empty string


    Well, that's the default config. It's describtion is:

    ##################################################################
    # Main settings

    # 'version' is one of predefined variables. It is set to husky
    # version like MAJOR.MINOR.PATHLEVEL. We may want to check it
    # first to eliminate problems with incompatible config and binaries.
    if "[version]"=="1.9.0"
    ###

    I'm reading "It is set to..." that the setting is done already. But i don't know where or if that's the designed intention.

    Do i have to set the version by myself or is it done by husky from internal versions inside the modules?

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)
  • From Michael Dukelsky@2:5020/1042 to Kai Richter on Wednesday, April 20, 2022 11:07:22
    Hello Kai,

    Tuesday April 19 2022, Kai Richter wrote to Alle:

    Fresh FreeBSD system, husky compiled with minimal conditions, sample configs with "gmake en". hpt without parameters start with: "hpt/fbsd
    1.9 2022-02-08". Config path set, compiled and confirmed found by
    tparser.

    tparser/fbsd 1.9 2022-02-08
    Test /home/test/husky/config for all modules
    B 10:34:00 Enviroment variable [version] (used in config file /home/test/husky/config) is not defined and is replaced with empty
    string


    Well, that's the default config. It's describtion is:

    ##################################################################
    # Main settings

    # 'version' is one of predefined variables. It is set to husky
    # version like MAJOR.MINOR.PATHLEVEL. We may want to check it
    # first to eliminate problems with incompatible config and binaries.
    if "[version]"=="1.9.0"
    ###

    I'm reading "It is set to..." that the setting is done already. But i don't know where or if that's the designed intention.

    The sample config was written by Nick Voronin in 2010. Maybe he wanted to implement the feature but he never did it. So in fact 'version' has no value in
    a configuration file.

    Do i have to set the version by myself

    What for? Do you want to write a config you will distribute?

    or is it done by husky from
    internal versions inside the modules?

    No.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)
  • From Kai Richter@2:240/77 to Michael Dukelsky on Thursday, April 21, 2022 02:37:40
    Hello Michael!

    20 Apr 22, Michael Dukelsky wrote to Kai Richter:

    The sample config was written by Nick Voronin in 2010. Maybe he wanted
    to implement the feature but he never did it. So in fact 'version' has
    no value in a configuration file.

    Do i have to set the version by myself

    What for? Do you want to write a config you will distribute?

    When i thought about that in the light of the moon i think "what for" is a good
    question. The version value would be useful when you want to operate different husky versions from the same config file. If someone needs to run different versions then i would be a clean and clear line to split that config into different files.

    or is it done by husky from
    internal versions inside the modules?

    No.

    Thanks. I will remove that line from my fresh config.

    Regards

    Kai

    --- GoldED+/LNX 1.1.4.7
    * Origin: Monobox (2:240/77)
  • From Michael Dukelsky@2:5020/1042 to Kai Richter on Friday, April 22, 2022 12:43:30
    Hello Kai,

    Tuesday April 19 2022, Kai Richter wrote to Alle:

    # 'version' is one of predefined variables. It is set to husky
    # version like MAJOR.MINOR.PATHLEVEL. We may want to check it
    # first to eliminate problems with incompatible config and binaries.
    if "[version]"=="1.9.0"

    I have deleted the 'version' check from the sample config. Thanks for the report.

    Michael

    ... node (at) f1042 (dot) ru
    --- GoldED+/LNX 1.1.5-b20180707
    * Origin: Moscow, Russia (2:5020/1042)